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Introduction to Simulate ONTAP 

Simulate ONTAP is a simulator for running ONTAP software. It enables you to test 

the features of ONTAP without having to buy new hardware or disturb your 

production environment.  

Simulate ONTAP is a VMware virtual machine that runs on a hypervisor. You can run 

Simulate ONTAP on a Windows or a Mac system. 

Supported VMware applications 

You can install Simulate ONTAP only on certain VMware applications. 

You need to install one of the following VMware applications on the host system to 

use Simulate ONTAP: 

• VMware Workstation Pro 

• VMware Workstation Player  

• VMware Fusion 

Limitations and unsupported features 

Simulate ONTAP supports most ONTAP functionality and most of its features. 

However, Simulate ONTAP has some functional limitations and does not support 

some ONTAP features because of the virtualization architecture. 

Simulate ONTAP has the following limitations: 

• Non-Volatile RAM (NVRAM) is simulated and is not persistent. 

Data loss might occur after power cycles. You must shut down the simulator 

properly to avoid data loss. 

• You can have a maximum of four simulated disk shelves with 14 disk drives per 

shelf, for a total of 56 drives per simulator. 

Note: SSD disk drive type is not supported. 

• Each simulated drive is limited to 9 GB. 
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Note: The simulator image comes pre-configured with 28 1 GB disks; 14 each on 

simulated disk shelves 0 and 1. Simulated disk shelves 2 and 3 are not 

populated. You can configure up to a maximum of 220 GB total space for each 

Simulate ONTAP node. 

• You can create 64-bit aggregates, but they are limited to a maximum of 9 GB per 

simulated disk drive. 

• Simulate ONTAP is not suitable for applications that require high performance or 

heavy I/O. 

• No more than two instances of the simulator can be booted simultaneously. 

Simulate ONTAP does not support the following features: 

• High Availability (CFO/SFO) 

• Fiber channel and SAN connectivity 

• RLM (Remote LAN Module) 

• CFE, BIOS, shelf FW, and so on 

• Multipathing 

Downloading Simulate ONTAP software 

The Simulate ONTAP software is a set of VMware files that have been packaged in 

an .ova file. You need to download the appropriate software and license files from 

the NetApp Support Site. 

Steps 

1. Log in to the NetApp Support Site at https://mysupport.netapp.com/. 

2. Go to the Tools section. 

3. Search for and select Simulate ONTAP to open the Download page. 

4. Download Simulate ONTAP 9.13.1 for VMware Workstation, VMware Player, 

and VMware Fusion. 

5. Save the *.ova file to the applicable location: 

https://mysupport.netapp.com/
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If you are downloading to... Then... 

A Windows system Save the file to the C:\Virtual Machines folder. 

A Mac system Save the file to the download folder. 

6. Click CMode Licenses file to get the list of ONTAP licenses that you need to 

unlock certain ONTAP features. 

Installing Simulate ONTAP on a Windows 
system 

You can install Simulate ONTAP on a Windows system and test the features of 

ONTAP. 

In a Windows system, you need to have one of the following VMware applications 

installed before you can run Simulate ONTAP: 

• VMware Workstation Pro 

• VMware Workstation Pro Player 

Windows system requirements 

You must ensure that the hardware and software prerequisites are met before 

installing Simulate ONTAP on a Windows system.  Also ensure that you have 

administrative privileges.  

Hardware requirements 

• Dual core 64-bit Intel or AMD system 

• 6 GB of RAM for one instance of the simulator 

• 12 GB of RAM for two instances of the simulator 

• 40 GB of free disk space for each instance of the simulator 

• VT support for Intel system 

Software requirements 

• Microsoft Windows 10 

• VMware Workstation 16.1.2 Pro or VMware Workstation 16.1.2 Player. 
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Enabling the VT feature 

To install Simulate ONTAP on a Windows system, you must enable the VT feature. 

The VT can be referred to as Vanderpool Technology, Virtualization Technology, or 

Virtual Machine Extensions. The VT setting can be found under a Security or CPU 

screen in the BIOS. 

About this task 

By default, VT is disabled on an Intel-based system. 

Steps 

1. Access the system BIOS while booting your laptop or desktop. 

2. In the BIOS, enable VT if it is not already enabled. 

3. Save the changes to the BIOS settings and then turn off the system. 

4. Turn on the system again. 

Note: If you reboot the system without turning it off, VT is not enabled. 

Installing Simulate ONTAP on VMware Workstation Pro 

You can download and install VMware Workstation Pro on a Windows laptop or 

desktop, configure the VMware Workstation Pro for Simulate ONTAP, start Simulate 

ONTAP Guest OS on the VMware Workstation Pro, and configure the network 

adapters on the VMware Workstation Pro. 

Note: You cannot install multiple versions of VMware Workstation Pro on the same 

host. 

For information about installing VMware Workstation Pro software, and for VMware 

Workstation Pro documentation, see the VMware Web site. 

Related information 

VMware Workstation Pro software 

Workstation Pro User Manual 

http://www.vmware.com/
http://downloads.vmware.com/d/
https://docs.vmware.com/en/VMware-Workstation-Pro/index.html
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Starting Simulate ONTAP on VMware Workstation Pro 

You must start Simulate ONTAP on VMware Workstation Pro to access the Simulate 

ONTAP console. 

Steps 

1. Click Start > All Programs > VMware > VMware Workstation. 

2. In the VMware Workstation window, click File > Open. 

3. In the Open window, select the .ova file you previously downloaded and click 

Open. 

4. In the Import Virtual Machine window, provide a name and local storage path 

for the new virtual machine, and then click Import. 

5. In the virtual machine tab, click the Power on this virtual machine icon. 

 

Installing Simulate ONTAP on VMware Workstation 
Player  

You can download and install the VMware Workstation Player on a Windows laptop 

or desktop, start Simulate ONTAP, set preferences for the Simulate ONTAP virtual 

machine, and configure network adapters on the VMware Workstation Player. 

For information about installing VMware Workstation Player software and VMware 

Workstation Player documentation, see the VMware Web site. 

http://www.vmware.com/
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Related information 

VMware Workstation Player software 

VMware Workstation Player Getting Started Guide 

Starting Simulate ONTAP on VMware Workstation Player  

You must start the Simulate ONTAP virtual machine to configure ONTAP in the 

VMware Workstation Player console. 

Steps 

1. Click Start > All Programs > VMware > VMware Workstation Player. 

2. In the VMware Workstation Player window, click Open a Virtual Machine. 

 

3. In the Open Virtual Machine window, select the .ova file you previously 

downloaded and click Open. 

4. In the Import Virtual Machine window, provide a name and local storage path 

for the new virtual machine and then click Import. 

http://downloads.vmware.com/d/
https://docs.vmware.com/en/VMware-Workstation-Player/index.html
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Result 

Simulate ONTAP opens in the VMware Workstation Player console. 

 

Installing Simulate ONTAP on a Mac system 

You can install Simulate ONTAP on a Mac operating system to test the features of 

ONTAP. 

Mac system requirements 

You must ensure that the hardware and software prerequisites are met before 

installing Simulate ONTAP on a Mac (Apple) operating system. Also ensure that you 

have administrative privileges. 

Hardware requirements 

• Intel Core 2 Duo processor 

• 6 GB of RAM for one instance of the simulator 

• 12 GB of RAM for two instances of the simulator 

• 40 GB of free disk space for each instance of the simulator 

• Physical Address Extension (PAE) support 

Software requirements 

• Mac OS X 11 (validated on 11.4) 

• VMware Fusion 12.1.1 
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Installing Simulate ONTAP on VMware Fusion 

You can download and install VMware Fusion on a Mac (Apple) system, configure 

VMware Fusion to run Simulate ONTAP, add Simulate ONTAP on VMware Fusion, 

start Simulate ONTAP, and configure the network adapters on VMware Fusion. 

For information about installing VMware Fusion software and VMware Fusion 

documentation, see the VMware Web site. 

Related information 

VMware Fusion software 

VMware Fusion documentation 

Adding Simulate ONTAP on VMware Fusion 

To install Simulate ONTAP on VMware Fusion, you must add Simulate ONTAP to the 

virtual machine library by using the VMware Fusion software. 

Steps 

1. On the desktop, click Applications. 

2. In the Applications window, click VMware Fusion. 

 

3. Click Cancel on the Select the Installation Method screen.  

4. Click File > Import. 

5. In the Choose an Existing Virtual Machine window, choose the .ova file you 

downloaded and click Continue. 

http://www.vmware.com/
http://downloads.vmware.com/d/
https://docs.vmware.com/en/VMware-Fusion/index.html
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6. Provide a name for the new virtual machine in the Save As text box and then 

click Save. 

7. In the Finished window, click Finish to run the virtual machine.  

Result 

The added Simulate ONTAP virtual machine appears in the Virtual Machine Library. 

 

 

Starting Simulate ONTAP on VMware Fusion 

You must start the Simulate ONTAP virtual machine to configure ONTAP in the 

VMware Fusion console. 
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Steps 

1. On the desktop, click Applications. 

2. In the Applications window, click VMware Fusion. 

 

3. Click Cancel on the Select the Installation Method screen.  

4. Select Window > Virtual Machine Library. 

5. Select the imported virtual machine and click the Play icon to start it. 

 

Using Simulate ONTAP: Single node 

Start and configure a single node cluster using Simulate ONTAP, VMware, and 

System Manager.  

Steps 

1. After a few minutes from starting the virtual machine, you receive a message to 

log in to System Manager to complete cluster setup. This message includes an 
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IP address. Copy this IP address and paste it into your browser address bar to 

open System Manager.  

2. Ignore the message indicating that the partner node is not found.  

3. Configure the single node cluster in System Manager. Follow the on-screen 

prompts. For more information, see the System Manager documentation.  

 

Using Simulate ONTAP: Two nodes 

Configure a Two Node Cluster  

Start and configure a two node cluster using Simulate ONTAP, VMware, System 

Manager, and the command line.  

Steps 

1. Create the first Simulate ONTAP virtual machine and name it node1. 

2. Power on the node1 virtual machine. 

Note: DO NOT OPEN SYSTEM MANAGER UNTIL INSTRUCTED IN THESE STEPS. 

3. Create the second Simulate ONTAP virtual machine and name it node2. 

4. Power on the node2 virtual machine. 

Change the system ID and serial number of the second node before joining the 

cluster as shown in the following steps. 

https://docs.netapp.com/us-en/ontap/task_configure_ontap.html
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5. Press the space bar when the Hit [Enter] to boot immediately, or 

any other key for command prompt. Booting in 10 seconds... 

message is displayed in the console of node2. 

6. You should see a VLOADER> prompt. 

7. Change the serial number and system ID for this node: 

a) VLOADER> setenv SYS_SERIAL_NUM 4034389-06-2 

b) VLOADER> setenv bootarg.nvram.sysid 4034389062 

8. Verify that the information was saved correctly: 

a) VLOADER> printenv SYS_SERIAL_NUM 

b) VLOADER> printenv bootarg.nvram.sysid 

9. Enter the boot command to boot the node:  

a) VLOADER> boot 

10. The simulator begins the boot process with the new system ID and serial 

number. 

11. After the IP address shows for node2, go back to node1 and open the System 

Manager in a browser window using the IP address that is shown in the console. 

12. You receive a message indicating that the partner node details were not found. 
Ensure that both the nodes were detected by cross checking the serial numbers 
(4082368-50-7 and 4034389-06-2) displayed in the message.  

13. Follow the on-screen prompts to configure the cluster. For more information, see 

the System Manager help. 

14. Click Submit. 

15. After the cluster creation is successful, you are redirected to the cluster IP 

provided earlier. 

16. Log in to the System Manager using the password provided earlier. 

17. Open Network > Overview and pick an IP address with a Type of Cluster and 

starting with 169.254.x.x in the Network interfaces section. 

18. Open the node2 virtual machine console, login with admin and enter the 

following command to join node1. 

https://docs.netapp.com/us-en/ontap/task_configure_ontap.html
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“cluster join -clusteripaddr <IP address picked in the 

previous step>” 

Wait until a message stating “This node has joined to cluster” is 

displayed. 

Disabling root snapshots  

Root snapshots consume a large amount of space on the root volume with snapshots 

of log files. If you are concerned about running out of space on your root volume, you 

should disable root snapshots before creating aggregates and volumes. 

Steps  

1. From the command line, enter run local. 

This takes you into the node shell. 

2. Delete all existing snapshots on the root volume and suppress confirmation 

request. 

snap delete –a –f vol0 

3. Disable the automatic snapshot schedule. 

snap sched vol0 0 0 0 

4. Enable snapshot autodelete. 

snap autodelete vol0 on 

5. Set the snapshot autodelete threshold to 35% for the volume free space. This 

guarantees the volume has a minimum of free space equal to 35% of its overall 

size. 

snap autodelete vol0 target_free_space 35 

6. Confirm the autodelete has been configured correctly. 

snap autodelete vol0 

Expanding the root volume size  

If your root volume is too small, you can expand it. Your root aggregate must have 

enough free space to accommodate an increase in the size of your root volume. 

Steps  
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1. If necessary, add more disks to your root aggregate to increase its size and 

accommodate the additional space needed in your root volume. 

storage aggregate add-disks -aggregate aggr0 -diskcount <n> 

2. Set the root volume to a new size. 

volume size -vserver <vserver_name> -volume vol0 -new-size 

<new_size> 

3. View the root volume size details to verify the new size. 

volume show -volume vol0 

 

Evaluating ONTAP 

Explore ONTAP using Simulate ONTAP and the ONTAP documentation center. 

 

Troubleshooting 

If an IP address is not automatically configured, complete the following steps. 

Steps 

1. Open command prompt and execute “ipconfig” in Windows and “ifconfig” 

in Mac.  

2. Look for the ethernet network adapter “VMware Network Adapter VMnet8” 

in Windows and “vmnet8” in Mac. 

Windows example: 

Ethernet adapter VMware Network Adapter VMnet8: 

Connection-specific DNS Suffix  . . . . . . . : 

Link-local IPv6 Address. . . . . . . . . . . .: fe80::3179:c654:ddb2:7dfc%11 

IPv4 Address. . . . . . . . . . . . . . . . . : 192.168.201.1 

Subnet Mask . . . . . . . . . .  . . . . . . .: 255.255.255.0 

Default Gateway . . . . . . . . . . . . . . . : 

https://docs.netapp.com/ontap-9/index.jsp
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MAC Example: 

vmnet8:  

flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 

ether 00:50:56:c0:00:08  

inet 172.16.208.1 netmask 0xffffff00 broadcast 172.16.208.255 

3. Pick an unused IP from the subnet of “IPv4 Address” in Windows and “inet” 

in Mac. 

4. Login to the console of the virtual machine and execute the following command 

to configure the IP. 

network interface create -vserver Default -lif mgmt_auto -role node-mgmt -

address <IP picked in step 2> -netmask <Netmask of IP picked in step2> -home-

port e0c 

5. Use the following URL to login to System Manager: 

https://< IP picked in step 3> 

 

 

Appendix A: Configuring network access on 
the Ethernet port 

 

By default, network adapter 3 and 4 of Simulate ONTAP are configured as NAT / 

Share with my MAC. To access and mount the volumes created on Simulate 

ONTAP through the physical ethernet port of the laptop, please modify network 

adapter 4 to Bridged / Thunderbolt Ethernet and use e0d network port within 

Simulate ONTAP for mounting the volumes. This works only if the IP addresses and 

subnet are static. 
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How to send comments about documentation 
and receive update notifications  

You can help us to improve the quality of our documentation by sending us your 

feedback. You can receive automatic notification when production-level (GA/FCS) 

documentation is initially released or important changes are made to existing 

production-level documents. 

If you have suggestions for improving this document, send us your comments by 

email to doccomments@netapp.com.  

To help us direct your comments to the correct division, include in the subject line the 

product name, version, and operating system. 

If you want to be notified automatically when production-level documentation is 

released or important changes are made to existing production-level documents, 

follow Twitter account @NetAppDoc. 

You can also contact us in the following ways: 

 
• NetApp, Inc., 3060 Olsen Drive, San Jose, CA 95128, USA  

• Telephone: +1 (408) 822-6000 

• Fax: +1 (408) 822-4501 

• Support telephone: +1 (888) 463-8277 
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